HP Device Manager Backdoor

Security researcher Nicky Bloor found a backdoor in HP Device Manager. The product allows IT admins to manage HP Thin Client devices.

However, due to the backdoor account, a remote unauthorized attacker could gain elevated privileges on target systems. When coupled with other vulnerabilities, the adversary could even run remote commands with SYSTEM privileges.

Describing details about the backdoor to The Register, the researcher said,

This was a privileged user account with a password consisting of a single space character. The only reference to the user account was in a database log file included with the HP Device Manager software where log entries can be seen dating before I even installed the software…
Anyone with access to a server where HP Device Manager is installed could use this user account to gain complete control over the server.

Bloor also found some more vulnerabilities in the default configuration of the HP Device Manager (HPDM). Thus, it became possible for a remote attacker to connect to and control a server running HPDM with admin access.

HP Deployed A Fix… Lately

Upon discovering the vulnerability back in August 2020, Bloor reached out to HP who, according to him, remained unresponsive initially. Then, when the researcher expressed his intention to disclose the bug within 30 days, HP responded with a request for a 90-day disclosure period.

This compelled the researcher to disclose the bug publicly to protect the users in general. He also shared a potential fix in a series of tweets.

Shortly after the disclosure, HP deployed the fix while assigning multiple CVEs to Bloor’s discovered bugs. As described in their advisory,

Potential vulnerabilities have been identified with certain versions of HP Device Manager. These vulnerabilities may allow locally managed accounts within HP Device Manager to be susceptible to dictionary attacks due to weak cipher implementation (CVE-2020-6925) and allow a malicious actor to remotely gain unauthorized access to resources (CVE-2020-6926), and/or allow a malicious actor to gain SYSTEM privileges (CVE-2020-6927).

The bugs CVE-2020-6925 and CVE-2020-6926 affected all versions of HPDM. Whereas, CVE-2020-6927 only affected HP Device Manager 5.0.0, 5.0.1, 5.0.2, and 5.0.3.

The vendors have released fixes with HP Device Manager 5.0.4. Whereas, they will also release fixes with HP Device Manager 4.7 Service Pack 13.

The following two tabs change content below.

Abeerah has been a passionate blogger for several years with a particular interest towards science and technology. She is crazy to know everything about the latest tech developments. Knowing and writing about cybersecurity, hacking, and spying has always enchanted her. When she is not writing, what else can be a better pastime than web surfing and staying updated about the tech world! Reach out to me at: [email protected]



Source link