PoC vulnerability S2-052 of Apache Struts2
Metasploit Module:: https://github.com/rapid7/metasploit-framework/issues/8064
https://github.com/rapid7/metasploit-framework/pull/8924

source